Current Connectivity Issues
Incident Report for LeapFILE INC
Resolved
This incident has been resolved, we apologize for the inconvenience!
Posted Mar 23, 2023 - 09:42 PDT
Monitoring
A fix has been implemented, we are monitoring the results
Posted Mar 23, 2023 - 09:32 PDT
Identified
The issue has been identified and a fix is being issued.
Posted Mar 23, 2023 - 09:14 PDT
Investigating
We are currently investigating a service outage
Posted Mar 23, 2023 - 09:06 PDT
This incident affected: Web Portal, E-Mail Sending, and Login / SSO.